Config
4IXP Support Config

Config

On this page you will find a number of configuration examples for software and various operating systems.

Endpoint
Server IPv4 Address 198.51.100.1
Server IPv6 Address 2001:db8:abcd::1
Client IPv4 Address 3.239.117.1
Peers
Server Autonomous System Number 35708
Server IPv4 Address 185.1.125.1
Server IPv6 Address 2001:7f8:d0::8b7c:1
Server IPv4 Address 185.1.125.2
Server IPv6 Address 2001:7f8:d0::8b7c:2
Server IPv4 Address 185.1.125.3
Server IPv6 Address 2001:7f8:d0::8b7c:3
Client Autonomous System Number 65535
Client IPv4 Address 192.168.123.10
Client IPv6 Address 2001:db8:4b42::a

Linux

Endpoints

GRETAP
/bin/ip link add 4IXP type gretap local 3.239.117.1 remote 198.51.100.1 ttl 255
/bin/ip link set dev 4IXP up
/bin/ip addr add 192.168.123.10/24 dev 4IXP
/bin/ip addr add 2001:db8:4b42::a/64 dev 4IXP
VXLAN
/bin/ip link add 4IXP type vxlan local 3.239.117.1 remote 198.51.100.1 dstport 4789 id 123456 ttl 255
/bin/ip link set dev 4IXP up
/bin/ip addr add 192.168.123.10/24 dev 4IXP
/bin/ip addr add 2001:db8:4b42::a/64 dev 4IXP
Ethernet over IP
# install
wget https://raw.githubusercontent.com/4b42/4ixp/master/eoip/install.sh -O /tmp/eoip.sh
chmod +x /tmp/eoip.sh
/tmp/eoip.sh
rm -f /tmp/eoip.sh
# config
cat << EOF > /etc/eoip.cfg
[eoip4ixp]
id=123456
dst=198.51.100.1
EOF
/usr/local/bin/eoip /etc/eoip.cfg
/bin/ip addr add 192.168.123.10/24 dev eoip4ixp
/bin/ip addr add 2001:db8:4b42::a/64 dev eoip4ixp

Peers

IPv4
cat << EOF > /etc/bird/bird.conf
router id 192.168.123.10;
protocol device {
   scan time 10;
}
protocol bgp rs1
{
   local as 65535;
   source address 192.168.123.10;
   import all;
   export none;
   neighbor 185.1.125.1 as 35708;
   password "SamplePassword";
}
protocol bgp rs2
{
   local as 65535;
   source address 192.168.123.10;
   import all;
   export none;
   neighbor 185.1.125.2 as 35708;
   password "SamplePassword";
}
protocol bgp rs3
{
   local as 65535;
   source address 192.168.123.10;
   import all;
   export none;
   neighbor 185.1.125.3 as 35708;
   password "SamplePassword";
}
EOF
IPv6
cat << EOF > /etc/bird/bird.conf
router id 192.168.123.10;
protocol device {
   scan time 10;
}
protocol bgp rs1
{
   local as 65535;
   source address 2001:db8:4b42::a;
   import all;
   export all;
   neighbor 2001:7f8:d0::8b7c:1 as 35708;
   password "SamplePassword";
}
protocol bgp rs2
{
   local as 65535;
   source address 2001:db8:4b42::a;
   import all;
   export all;
   neighbor 2001:7f8:d0::8b7c:2 as 35708;
   password "SamplePassword";
}
protocol bgp rs3
{
   local as 65535;
   source address 2001:db8:4b42::a;
   import all;
   export all;
   neighbor 2001:7f8:d0::8b7c:3 as 35708;
   password "SamplePassword";
}
EOF

MikroTik RouterOS

Endpoints

/interface eoip add !keepalive name=4IXP local-address=3.239.117.1 remote-address=198.51.100.1 tunnel-id=123456
/ip address add address=192.168.123.10/24 interface=4IXP
/ipv6 address add address=2001:db8:4b42::a/64 interface=4IXP

Peers

/routing bgp instance set default as=65535 disabled=no
/routing bgp peer
# 1. Server
add instance=default name=4IXPv4rs1 remote-address=185.1.125.1 remote-as=35708 tcp-md5-key=SamplePassword ttl=default
add instance=default name=4IXPv6rs1 remote-address=2001:7f8:d0::8b7c:1 remote-as=35708 tcp-md5-key=SamplePassword ttl=default
# 2. Server
add instance=default name=4IXPv4rs2 remote-address=185.1.125.2 remote-as=35708 tcp-md5-key=SamplePassword ttl=default
add instance=default name=4IXPv6rs2 remote-address=2001:7f8:d0::8b7c:2 remote-as=35708 tcp-md5-key=SamplePassword ttl=default
# 3. Server
add instance=default name=4IXPv4rs3 remote-address=185.1.125.3 remote-as=35708 tcp-md5-key=SamplePassword ttl=default
add instance=default name=4IXPv6rs3 remote-address=2001:7f8:d0::8b7c:3 remote-as=35708 tcp-md5-key=SamplePassword ttl=default